このカテゴリーの記事一覧: ネットワーク

Cisco Catalyst 2955

(0/n)
カテゴリー : ネットワーク タグ :

産業用Ethernet Switch Catalyst2955を入手

製品情報/English
Datasheet/日本語
電源がDC24Vという点を除けば、ファンレスなので家Labで触るには最適。
持っている電源ではDC18.5Vまでしか供給できないがぎりぎり18Vが入力レンジ下限のためどうにか通電。
ひとまずは以下Processにて初期化
※他Switchと違ってMODEボタンが存在しないので手順が違う
C2955 Boot Loader (C2955-HBOOT-M) Version 12.1(12r)EA1, RELEASE SOFTWARE (fc1)
Compiled Mon 13-Jan-03 13:14 by madison
WS-C2955T-12 starting…
Base ethernet MAC Address: 00:11:20:19:**:**
Xmodem file system is available.
Initializing Flash…
flashfs[0]: 86 files, 3 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 6158848
flashfs[0]: Bytes available: 1582592
flashfs[0]: flashfs fsck took 7 seconds.
…done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4
*** The system will autoboot in 15 seconds ***
Send break character to prevent autobooting.
Break Key 押下
The system has been interrupted prior to initializing the
flash filesystem. The following commands will initialize
the flash filesystem, and finish loading the operating
system software:
flash_init
load_helper
boot
switch:
switch: flash_init
Initializing Flash…
…The flash is already initialized.
switch: boot
以下Boot Message…

Comment PermaLink

NEC UNIVERGE IX2015設定

(0/n)
カテゴリー : ネットワーク タグ :

このところIX2k/3kの話題も落ち着いてきたようですが備忘録を兼ねて
NTTフレッツ/マルチPPPoEでの2-ISPマルチホーミング設定のサンプルコンフィグ。
## host名設定
hostname hogehoge
## タイムゾーン設定
timezone +09 00
## ユーザー設定
username admin password hash XXXXXXXXXXXXXX administrator
## NTP設定 (MFEED)
ntp ip enable
ntp server 210.173.160.27
ntp server 210.173.160.57
ntp server 210.173.160.87
ntp interval 3600
## syslog設定
logging buffered 131072
logging subsystem all warn
logging timestamp datetime
## UFSキャッシュ有効化
ip ufs-cache max-entries 20000
ip ufs-cache enable
## FaE0/0.1 と FaE0/0.2 (PPPoEセッション)にてマルチホーミング
ip route default FastEthernet0/0.1 distance 200
ip route default FastEthernet0/0.2 distance 100
## フレッツスクエア経路 (セッション数不足で未使用)
ip route 220.210.194.0/25 FastEthernet0/0.3
## DHCP有効
ip dhcp enable
## ACL設定
ip access-list all-block deny ip src any dest any
ip access-list all-forward permit ip src any dest any
# ACL設定 / マルチホーミングのDNSアクセス制御
ip access-list isp1-dns permit tcp src any sport any dest /16 dport eq 53
ip access-list isp2-dns permit tcp src any sport any dest /16 dport eq 53
# ACL設定 / マネージメント制御
ip access-list management permit ip src 192.168.100.0/16 dest any
ip access-list management permit ip src 192.168.200.0/16 dest any
ip access-list management permit ip src 192.168.300.0/16 dest any
# ACL設定 / NetBIOSフィルタ
ip access-list nb-block deny tcp src any sport eq 135 dest any dport any
ip access-list nb-block deny tcp src any sport any dest any dport eq 135
ip access-list nb-block deny tcp src any sport range 137 139 dest any dport any
ip access-list nb-block deny tcp src any sport any dest any dport range 137 139
ip access-list nb-block deny tcp src any sport any dest any dport eq 445
ip access-list nb-block deny tcp src any sport eq 445 dest any dport any
# ACL設定 / Policy Based Routing
ip access-list pbr-in-list permit ip src any dest 10.0.0.0/8
ip access-list pbr-in-list permit ip src any dest 172.16.0.0/12
ip access-list pbr-in-list permit ip src any dest 192.168.0.0/16
ip access-list pbr-out-list permit ip src 192.168.200.1/32 dest any
ip access-list pbr-out-list permit tcp src 192.168.300.251/32 sport eq 22 dest any dport any
## DNSキャッシュ無効
no dns cache address-database
## DNS Proxy設定
proxy-dns ip enable
proxy-dns ip query-interval 1
proxy-dns interface FastEthernet0/0.1 priority 200
proxy-dns interface FastEthernet0/0.2 priority 150
## Telnet有効
telnet-server ip enable
telnet-server ip access-list management
## マルチホーミング経路制御
#DNSアクセス制御(100/200)
route-map pbr-map permit 100
match ip address access-list isp1-dns
set interface FastEthernet0/0.2
!
route-map pbr-map permit 200
match ip address access-list isp2-dns
set interface FastEthernet0/0.1
!
#特定端末のSauce based routing(400/500)
route-map pbr-map permit 400
match ip address access-list pbr-in-list
set interface Loopback0.0
set ip next-hop 192.168.200.251
!
route-map pbr-map permit 500
match ip address access-list pbr-out-list
set interface FastEthernet0/0.1
## PPPoEアカウント設定
ppp profile isp_isp1
authentication myname
authentication password
!
ppp profile isp_isp2
authentication myname
authentication password
!
ppp profile square
authentication myname guest@flets
authentication password guest@flets guest
## DHCP設定
ip dhcp profile dhcp_open
assignable-range 192.168.100.129 192.168.100.192
subnet-mask 255.255.255.0
dns-server 192.168.100.254
fixed-assignment 192.168.100.160 AA:BB:CC:DD:EE:FF ##固定割り当て
!
ip dhcp profile dhcp_local
assignable-range 192.168.200.129 192.168.200.192
subnet-mask 255.255.255.0
dns-server 192.168.200.254
!
ip dhcp profile dhcp_tech
assignable-range 192.168.300.129 192.168.300.192
subnet-mask 255.255.255.0
dns-server 192.168.300.253
## 物理インターフェイス
device FastEthernet0/0
!
device FastEthernet0/1
!
device FastEthernet1/0
vlan-group 1 port 1
vlan-group 2 port 2 3
vlan-group 3 port 4
!
device BRI1/0
isdn switch-type hsd128k
## 論理インターフェイス
interface FastEthernet0/0.0
no ip address
shutdown
!
interface FastEthernet0/1.0
no ip address
shutdown
!
interface FastEthernet1/0.0
no ip address
shutdown
!
interface BRI1/0.0
encapsulation ppp
no auto-connect
no ip address
shutdown
!
# ISP1-PPPoE設定
interface FastEthernet0/0.1
encapsulation pppoe
auto-connect
ppp binding isp_isp2
ip address ipcp
ip tcp adjust-mss auto
ip napt enable
ip napt translation max-entries 25000
ip napt static 192.168.200.1 tcp 5800
ip napt static 192.168.200.1 tcp 5900
ip napt service ssh-trans 192.168.200.1 22 tcp 10022
ip filter nb-block 1 in
ip filter all-forward 65535 in
ip filter all-forward 65535 out
no shutdown
!
# ISP2-PPPoE設定
interface FastEthernet0/0.2
encapsulation pppoe
auto-connect
ppp binding isp_isp1
ip address ipcp
ip tcp adjust-mss auto
ip napt enable
ip napt translation max-entries 25000
ip napt translation max-entries 25000
ip napt static 192.168.200.1 tcp 5800
ip napt static 192.168.200.1 tcp 5900
ip napt service ssh-trans 192.168.200.1 22 tcp 10022
ip filter nb-block 1 in
ip filter all-forward 65535 in
ip filter all-forward 65535 out
no shutdown
!
# フレッツスクエア-PPPoE設定 (未使用)
interface FastEthernet0/0.3
encapsulation pppoe
auto-connect
ppp binding square
ip address ipcp
ip mtu 1454
ip tcp adjust-mss auto
ip napt enable
ip filter nb-block 1 in
ip filter all-forward 65535 in
ip filter all-forward 65535 out
shutdown
!
interface FastEthernet1/0.1
encapsulation pppoe
auto-connect
no ip address
shutdown
!
interface FastEthernet1/0.2
encapsulation pppoe
auto-connect
no ip address
shutdown
!
# VLAN-Group1
interface FastEthernet1/0:1.0
description OPEN-NET
ip address 192.168.100.254/24
ip mtu 1454
ip tcp adjust-mss 1414
ip dhcp binding dhcp_open
ip policy route-map pbr-map
no shutdown
!
# VLAN-Group2
interface FastEthernet1/0:2.0
description LOCAL-NET
ip address 192.168.200.254/24
ip mtu 1454
ip tcp adjust-mss 1414
ip dhcp binding dhcp_local
ip policy route-map pbr-map
no shutdown
!
# VLAN-Group3
interface FastEthernet1/0:3.0
description TECH-NET
ip address 192.168.300.253/24
ip mtu 1454
ip tcp adjust-mss 1414
ip dhcp binding dhcp_tech
ip policy route-map pbr-map
no shutdown
!
interface Loopback0.0
ip address 127.0.0.1/32
!
interface Null0.0
no ip address

Comment PermaLink

ネットワークエミュレータ netem

(0/n)
カテゴリー : ネットワーク タグ :

ネットワークエミュレータ netem を試してみました。
複数NICを持っているLinux PCが確保できなかったのでとりあえず
Virtual PC上にインストールしたCentOS 5.4にて動作確認。
netem on Linux
まだ固定遅延のみですが、Ping応答に反映できていることが確認できました。とりあえず、近々に実PCに投入してオペレーション確立させます。

Comment PermaLink

nmapによるセッション負荷

(0/n)
カテゴリー : ネットワーク タグ :

PC—-(NW-A)====LAN[被検機(AR230E)]WAN====(NW-B)
    Syn Packet→
ネットワークIP
  NW-A:192.168.0.0
  NW-B:192.168.1.0
PC上のnmapからSynパケットをWAN側のセグメントで実在しないIP
に対して送信する。
(実在IPにSynを送るとRST ACTを戻されセッションが閉じる)
・コマンド
 C:> nmap -sS -n -P0 192.168.1.1/24
  -sS        とりあえずデフォルト
  -n         DNS解決なし
  -P0        Pingなし
  192.168.1.1/24  1?254が対象となる
結果から AR230EのNATテーブルは1024程度, TimeOutは600秒
参考値 IX2010(65000), Century(16000), SSG(4000or8000)

Comment PermaLink

SNMPエージェント

(0/n)
カテゴリー : ネットワーク タグ :

フリー
snmpwalkライクなことがWindows上で可能
http://hp.vector.co.jp/authors/VA031427/wsnmp/

Comment PermaLink

ネットワークツール覚書

(0/n)
カテゴリー : ネットワーク タグ :

– NetEnum ・・・ LAN内のIPアドレス一覧作成、各種コマンド実行ツール
http://www.vector.co.jp/soft/winnt/net/se312004.html
– PC検索ツール WhiteFox NetAdr 2007
LAN接続されたPCのコンピュータ名、IPアドレスを収集
http://www.vector.co.jp/soft/winnt/net/se418275.html

Comment PermaLink

ネットワークツール覚書 Part2

(0/n)
カテゴリー : ネットワーク タグ :
PCにsyslogソフトをインストールし運用
syslog-ng(Linux)
http://www.atmarkit.co.jp/fsecurity/rensai/unix_sec09/unix_sec01.html
Winsyslog(Windows有償)
http://adiscon.port139.co.jp/gaiyou_winsyslog2.htm
Logstorage(Windows有償)
http://www.logstorage.com/welcome/index.html
syslogフリーソフト
http://search.vector.co.jp/search?query=syslog&path=%2Fwin%2Fnet%2Fcomm%2Flog%2F
参考までですが、下記ツール
■nmapとは
 コマンドラインのポートスキャンツール。任意のIPアドレスやポートの
 スキャンを行うので、synアタックや大量の確立されないセッションの
 再現試験などにも利用できる。
 MACやIPアドレスの偽装パケットも送出可能。 
■namaとは
 任意の送受信IPアドレスおよびポートを指定し、負荷試験が可能!
 2台のPC間でTCPセッションを確立しつつ負荷試験ができる。
 ソフトウェアなので最大30Mくらいが限度。
■ ipsendwinとは
ipsendwinは、任意のMACフレームやIPパケットを生成し、ネットワーク上に
送信できるWindowsアプリケー ション。
特徴
・MACフレームであれば、どんな内容でも定義可能。
・MAC、IP、IPv6、TCP、ICMP、IGMP、ARPヘッダは簡単に設定可能。
・各プロトコルヘッダのチェックサム、ペイロード長等の自動計算モードを実装。
・IPアドレス、TCP/UDPポート番号をフレーム毎に加算して送信可能。
・多重起動することで、同時に複数種のフレームを送信可能。
・フレーム数、送信間隔を指定してトラフィック量を自由に調節可能。
・フレーム定義内容を保存可能。
・保存した複数のフレーム定義を指定した間隔で順番に送信可能。
(バッチ送信機能)
http://www.forest.impress.co.jp/lib/sys/wincust/contxtextn/attributer.html
ファイルのDate stampを自由に変えられます。
プログラムファイル管理に
日付を合わせ、時間をバージョン表示する、等。
作った書類を古い日付に偽装するには便利。
インストールするとファイルのプロパティにタブが一つ増えます。
Comment PermaLink

日本語環境で使えるFTP Server

(0/n)
カテゴリー : ネットワーク タグ :

FTP Server for Windows
クイックFTPサーバ
Tiny FTP Daemon
WarFTP Daemon
3CDaemon
GuildFTPd
BlackJumboDog
IIS

Comment PermaLink

分解:ファーストイーサネットハブ FE104

(0/n)
カテゴリー : コンピュータ, ネットワーク タグ :

FE104概要
NETGEAR社の4ポート 100BASE-TX ファーストイーサネットハブ、デュアルスピードハブなどの名で呼ばれているスイッチング機能のないハブです。バカハブと言ったほうがわかり易いでしょうか?
昨今では安価なスイッチングハブが出回っているのでデュアルスピードハブを目にする機会はあまりありませんが、実ネットワーク上でパケット・モニタリングを行う場合に重宝します。
2006-07-10-a1
写真の機器は4番ポートが死んでいるため埋めてあります。
 
さくっと分解
基板表面
2006-07-10-a3
 
基板裏面
2006-07-10-a2
がっつり噛んでいる固定のツメもなく、すんなりと分解完了。
中はボード一枚のすっきりとした構成、部品実装も基板表面でした。
 
主な部品
・LITEON Communications製 LC82C188 (詳細不明,コントローラ??)
・Quality Semiconductor(現IDT)製 QS6611 (PHY)
・25MHzの発振水晶 (上記2パーツのどちらかor両方にクロック供給)
・Bel Fuse製 S558-5999-86 (Single-Port Transformer Modules)
・Amphenol製 (RJ-45 Connectors)
流石に古い機器なので部品の情報が手に入りにくいです。
電源部拡大
2006-07-10-a4
基板の表面写真の左上部分の別角度写真です。
AC-DCアダプタにて生成されたDC12Vを受ける部分。付属アダプタは昔ながらの重くて大きめのものだったので非スイッチング,非安定化だと思われます。アダプタ不良で現在は秋月電子製の12VスイッチングACアダプタを使用しています。
写真手前にNational SemiconductorのLM2576T-5.0P+なるレギュレータが写ってます。型番からするに5.0Vの電圧整流のよう、ここで5Vに整流された出力が各デバイスに供給されるんですね。
それでもってレギュレータの入出力各端に入るコンデンサが写真中央に。2個じゃなくて4個なのはなんででしょうかね。組み立てなおしてしまったので回路辿りは断念。コンデンサ刻印は[A],LOW ESR記述有り, シリーズ名等はないです。台湾のメーカーでしょうか・・・・。
 
今後の課題みたいな・・・
リピータ,スイッチの内部構成の理解がまだ甘いことを再認識、勉強せねば・・・・。にしてもこの手の情報のドキュメントが少ないのが痛いです。
自分なりに↓の構成なのかなということでひとまず納得
 RJ-45 Connector == Transformer == PHY == MII controller(コントローラ内?)
あとはレギュレータ周りの回路の理解、これは情報がそれなりにありそうですね。
(´-`).。oO(さてさて、次はなにをバラそうかな・・・)
 
参考LINK
[Link] NETGEAR FE104 製品ページ

Comment PermaLink

Firewall-Soft NEGiES

(0/n)
カテゴリー : ネットワーク タグ :

NEGiES UI
■メイン画面
定義したフィルタの現在の帯域(速度)や累積転送量を見ることが出来る。
直感で掴みやすい画面構成となっており、マニュアルを読まなくともある程度の操作をすることができ好感がもてる。
2006-02-20-a2
■フィルタ編集画面
フィルタを作成/編集する画面、双方のIP,Port単位での通信のフィルタを編集できる。
2006-02-20-a1
 
NEGiES 使用感
ルータ配下にあるPCに必要以上のセキュリティは不要と考えているののもありファイアーウォールよりも帯域制限に利便性を感じた。
PCでWeb,FTPなどのサーバを立て、高速な回線同士の通信を行うとPCのHDDに大きな負荷がかかってしまう。それを防止するのにもってこいなソフトである。
 
参考LINK
[Link] -=NEGiES Official Homepage=-

Comment PermaLink
top